App keeps stopping

  • 17 August 2019
  • 22 svar
  • 64 visningar

Användarnivå 2

Since 1-2 months my Vimla app stops right when I start it (or after username/password if I have to enter that). It used to function very well. Now I have to rely on Mitt Vimla which is ok as well, but the app was better.

I am running Android 7.1.1

App version 3.5.0

Already cleared cache and data but the issue remains.


22 svar

Användarnivå 2

Unfortunately I never received an update from @Emil_Vimla .

But I just noticed the app now works.

Pity for Vimla I am not using the Vimla SIM cards anymore.

Användarnivå 2

Hello @joostcolette,

I've not forgotten about you!

I've not got any information on your error report yet since I don't believe they've found the issue. I've talked to the people responsible for app-developing here at Vimla and given them your full report about the crashes alongside your subscription information (phone number, email etc. if they need to more info).

I promise I'll let you know as soon as I hear anything.

Regards,

Emil

Hej @Emil_Vimla , I hope still have not forgotten about this (although I did not receive a response last time….)

Joost

@joostcolette

Well, regretably this is just the way how Vimla works. You started this thread nine months ago giving Vimla very detailed observations about this error and Vimla has until this day done absolutely NOTHING.

We as customers have seen this behaviour from Vimla regarding so many issues. Vimla fails completely in dealing with problems and malfunctions in their services.

Användarnivå 2

@Emil_Vimla Hej,

Any update on the issue?

I am pretty sure the issue has nothing to do with my account. I tried another (brand new) Mitt Vimla account as well and I get the same issue.

This is the Android error report:

java.lang.NullPointerException: Attempt to invoke virtual method 'java.util.Iterator org.json.JSONObject.keys()' on a null object reference

at com.mixpanel.android.mpmetrics.PersistentIdentity.registerSuperProperties(PersistentIdentity.java:297)

at com.mixpanel.android.mpmetrics.MixpanelAPI.registerSuperProperties(MixpanelAPI.java:749)

at com.kevinejohn.RNMixpanel.RNMixpanelModule.registerSuperProperties(RNMixpanelModule.java:225)

at java.lang.reflect.Method.invoke(Native Method)

at com.facebook.react.bridge.JavaMethodWrapper.invoke(JavaMethodWrapper.java:372)

at com.facebook.react.bridge.JavaModuleWrapper.invoke(JavaModuleWrapper.java:158)

at com.facebook.react.bridge.queue.NativeRunnable.run(Native Method)

at android.os.Handler.handleCallback(Handler.java:883)

at android.os.Handler.dispatchMessage(Handler.java:100)

at com.facebook.react.bridge.queue.MessageQueueThreadHandler.dispatchMessage(MessageQueueThreadHandler.java:29)

at android.os.Looper.loop(Looper.java:224)

at com.facebook.react.bridge.queue.MessageQueueThreadImpl$4.run(MessageQueueThreadImpl.java:232)

at java.lang.Thread.run(Thread.java:919)


Användarnivå 2

Much appreciated

Användarnivå 6
Emblem +54

Hello @joostcolette,

I've not forgotten about you!

I've not got any information on your error report yet since I don't believe they've found the issue. I've talked to the people responsible for app-developing here at Vimla and given them your full report about the crashes alongside your subscription information (phone number, email etc. if they need to more info).

I promise I'll let you know as soon as I hear anything.

Regards,

Emil

Användarnivå 2

So on our account the issue persists on 4 phones:

  1. Oneplus 6 running Android 9 (wifes phone)
  2. Xiaomi Redmi K20 Pro (Mi 9T Pro) running Android 10 (my new phone, this is where the crash report comes from)
  3. Ulefone Power3 running Android 7 (my old phone)
  4. Oneplus 6T running Android 9 (sons phone)
Användarnivå 2

Below is the info of the crashes as I experience these on my new phone (Android 10).

Full report:

https://docs.google.com/document/d/1vVybXW-bpA4qRN...

====================


java.lang.NullPointerException: Attempt to invoke virtual method 'java.util.Iterator org.json.JSONObject.keys()' on a null object reference

at com.mixpanel.android.mpmetrics.PersistentIdentity.registerSuperProperties(PersistentIdentity.java:297)

at com.mixpanel.android.mpmetrics.MixpanelAPI.registerSuperProperties(MixpanelAPI.java:749)

at com.kevinejohn.RNMixpanel.RNMixpanelModule.registerSuperProperties(RNMixpanelModule.java:225)

at java.lang.reflect.Method.invoke(Native Method)

at com.facebook.react.bridge.JavaMethodWrapper.invoke(JavaMethodWrapper.java:372)

at com.facebook.react.bridge.JavaModuleWrapper.invoke(JavaModuleWrapper.java:158)

at com.facebook.react.bridge.queue.NativeRunnable.run(Native Method)

at android.os.Handler.handleCallback(Handler.java:883)

at android.os.Handler.dispatchMessage(Handler.java:100)

at com.facebook.react.bridge.queue.MessageQueueThreadHandler.dispatchMessage(MessageQueueThreadHandler.java:29)

at android.os.Looper.loop(Looper.java:221)

at com.facebook.react.bridge.queue.MessageQueueThreadImpl$4.run(MessageQueueThreadImpl.java:232)

at java.lang.Thread.run(Thread.java:919)


Användarnivå 2

Hej @emil_vimla

Is has been a while since this issue ocurred. And it still is not solved I noticed today. Both on my phone and on the phone of my wife.


Can you give an update of the progress of fixing this issue?

Användarnivå 6
Emblem +54

@Joel-Fransson

Thank you for letting us know! I'll add you to the error report so we get more examples for our developers to work with! :)

Regards,

Emil

Hi @Emil_Vimla,

Yes it crashes or "stops" almost immediately when opening the app, I just wanted to make my voice heard for your knowledge of this problem, if the problem would actually be caused due to the app itself or android etc. It has worked fine before on the same phone. I do not have another phone unfortunately.

Thank you for answering!

/Joel

Användarnivå 6
Emblem +54

Hello @Joel-Fransson,

It just crashes when trying to log in for you? Do you have access to another phone? Maybe an iPhone or another Android running a different OS? The best thing you can do to troubleshoot this is to contact us in the chat on vimla.se/support.

Regards, Emil

I have the same problem aswell! Also for about 1-2 months. Running androiod 7.0.

I also tried reinstall, clear cache/data, restart phone etc.


Användarnivå 2

@mlo When I started to use Vimla I also could not download the app from the Dutch Playstore. This is annoying but not unusual as I remember the Telia app also was/is not available for non-swedish phones/accounts.

But Vimla released it upon my request on 12 Sep 2017 (probably the same situation as with you).

.Apart from occasional hickups (I supose a bad data connection) I can't recall any issues with the app. The current issue (app stopping right after credentials are submitted) started "suddenly" (and on both phones we have the app installed on).

Användarnivå 6
Emblem +54

@mlo You're into something very interesting with the support of the app in a foreign Play Store. I just had words with our app developers and they said it should not even exist in the store or be downloadable if there was some form of limited availability.

@joostcolette Glad to hear that the issue with the app is the only thing you have trouble with here at Vimla. It should not matter if you don't have the simcard in your phone it should work anyway because it's not connected to the app in any way. Like I said earlier I have sent an error report to our developers about your account and your problem to find out why the problem is only shown in the app and not the web based "My Vimla".

I'll send you an update by email when/ if they find the problem.

Regards,

Emil

Användarnivå 6
Emblem +1

@joostcolette

I've used the app on both iPhone's and Android phones with non-Vimla cards in them or even without SIM-cards, but I haven't experienced more problems that way than while running the app on my regular Vimla phone.

On the other hand, I'm having a variety of problems with the app whatever phone I'm using. For instance, about one in there times the app isn't able to log in to my account and I have to kill it and start over.

I'm not sure if that's what you are experiencing too, I'm not sure I understood your initial post correctly. But my point is, there are all sorts of issues with this app but running it from another phone shouldn't be one of them.

It could be that you arer not using Swedish phones. When I first wanted to install the Vimla app it wasn't available since my phone was connected to the US Play Store. Apparently Vimla had (mistakenly) limited availability to the Swedish Play Store. Perhaps they have (mistakenly again, I guess) done something similar which prevents proper functionality on your Dutch phone?

It's a long shot. I'm using the app on my American phone and that works. But it could be something to ask the support to look in to.

(sorry for the long post, it's late, I'm tired, I didn't manage to write short)


Användarnivå 2

Hej borgus,

We do not have any issue with Vimla whatsoever, except for this nuisance with the app.

The 4G connection we have is very stable and fast. The pricemodel of Vimla is very flexible and their prices are very competitive. Next to that Vimla offers (a kind of) subscription model without the obligation to have a personnumber (which we do not have).

I do not see any reason to switch provider for our 4G router.


It is very likely that not having the Vimla SIM in the phone on which the app is installed has something to do with the stopping of the app. At least it has to be something specific to our situation, otherwise much more people would be complaining about the app.

I have read about the network/SIM issues Vimla has on the 2.0 platform but that has nothing to do with our app issue (besides: we are still on the old platform).

@joostcolette

Het maakt helemaal niet uit dat je Nederlandse kaarten hebt. VImla heeft zeer vreemde problemen. U zou waarschijnlijk een andere operator moeten hebben. De volgende keer dat u in Zweden bent, moet u veranderen.

Veel geluk

Användarnivå 2

My wife has exactly the same issue on her phone running Android 9. We use the same account.

Note we both use the app on a phone that does NOT have the Vimla SIM in it (we have our Dutch SIM in our phones).

Our Vimla SIM is in the 4G router in our holidayhouse in Sweden.

Användarnivå 6
Emblem +54

@joostcolette

I agree, I think this has something to do with the support of our app in your phone/ OS or maybe the account itself. I have sent an error-report to our developers so they can have a look as well.

Regards,

Emil

Användarnivå 2

Removing and re-installing does not solve the issue.

I need to find someone else to install on another phone, will come back on that. But I expect it is something between my phone and the app, otherwise you would have much more reports.....

Användarnivå 6
Emblem +54

Hi @joostcolette,

Thank you for your feedback about our Vimla app. I've sent the information forward to our developers so they can take a look and see if they can find the problem.

If you delete and re-install the app does the issue go away or is it still there?
Do you have access to another phone you can try the app in?

Regards,

Emil

Svara